<!DOCTYPE html>
<html lang="en-US">
<head >
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1" />
<title>Galaxy S10 Lite will sell in India for Rs. 39,999 - Sammy Hub</title>

<!-- This site is optimized with the Yoast SEO plugin v12.8 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/>
<link rel="canonical" href="https://sammyhub.com/2020/01/24/galaxy-s10-lite-will-sell-in-india-for-rs-39999/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Galaxy S10 Lite will sell in India for Rs. 39,999 - Sammy Hub" />
<meta property="og:description" content="Shortly after announcing the Galaxy Note10 Lite for the Indian market, Samsung has revealed the pricing and availability for the Galaxy S10 Lite. The phone&#8217;s Lite moniker doesn&#8217;t do justice as the phone seem to be nicely spec&#8217;d for modern needs. It is powered by Qualcomm&#8217;s Snapdragon 855 processor and packs in 8GB of RAM &hellip;" />
<meta property="og:url" content="https://sammyhub.com/2020/01/24/galaxy-s10-lite-will-sell-in-india-for-rs-39999/" />
<meta property="og:site_name" content="Sammy Hub" />
<meta property="article:publisher" content="https://facebook.com/sammyhub" />
<meta property="article:tag" content="Galaxy S10 Lite" />
<meta property="article:tag" content="Phones" />
<meta property="article:section" content="Phones" />
<meta property="article:published_time" content="2020-01-24T07:23:16+00:00" />
<meta property="og:image" content="https://sammyhub.com/wp-content/uploads/2020/01/GALAXY-S10-LITE.jpg" />
<meta property="og:image:secure_url" content="https://sammyhub.com/wp-content/uploads/2020/01/GALAXY-S10-LITE.jpg" />
<meta property="og:image:width" content="750" />
<meta property="og:image:height" content="667" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="Shortly after announcing the Galaxy Note10 Lite for the Indian market, Samsung has revealed the pricing and availability for the Galaxy S10 Lite. The phone&#8217;s Lite moniker doesn&#8217;t do justice as the phone seem to be nicely spec&#8217;d for modern needs. It is powered by Qualcomm&#8217;s Snapdragon 855 processor and packs in 8GB of RAM [&hellip;]" />
<meta name="twitter:title" content="Galaxy S10 Lite will sell in India for Rs. 39,999 - Sammy Hub" />
<meta name="twitter:site" content="@sammyhubcom" />
<meta name="twitter:image" content="https://sammyhub.com/wp-content/uploads/2020/01/GALAXY-S10-LITE.jpg" />
<meta name="twitter:creator" content="@sammyhubcom" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://sammyhub.com/#website","url":"https://sammyhub.com/","name":"Sammy Hub","potentialAction":{"@type":"SearchAction","target":"https://sammyhub.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://sammyhub.com/2020/01/24/galaxy-s10-lite-will-sell-in-india-for-rs-39999/#primaryimage","url":"https://sammyhub.com/wp-content/uploads/2020/01/GALAXY-S10-LITE.jpg","width":750,"height":667,"caption":"Samsung Galaxy S10 Lite"},{"@type":"WebPage","@id":"https://sammyhub.com/2020/01/24/galaxy-s10-lite-will-sell-in-india-for-rs-39999/#webpage","url":"https://sammyhub.com/2020/01/24/galaxy-s10-lite-will-sell-in-india-for-rs-39999/","inLanguage":"en-US","name":"Galaxy S10 Lite will sell in India for Rs. 39,999 - Sammy Hub","isPartOf":{"@id":"https://sammyhub.com/#website"},"primaryImageOfPage":{"@id":"https://sammyhub.com/2020/01/24/galaxy-s10-lite-will-sell-in-india-for-rs-39999/#primaryimage"},"datePublished":"2020-01-24T07:23:16+00:00","dateModified":"2020-01-24T07:23:16+00:00","author":{"@id":"https://sammyhub.com/#/schema/person/6c719939e1a91e8e5fd662c89096c915"}},{"@type":["Person"],"@id":"https://sammyhub.com/#/schema/person/6c719939e1a91e8e5fd662c89096c915","name":"Siddhanth","image":{"@type":"ImageObject","@id":"https://sammyhub.com/#authorlogo","url":"https://secure.gravatar.com/avatar/b44f3be9bac46c2980594e16f4e08d73?s=96&d=mm&r=g","caption":"Siddhanth"},"sameAs":[]}]}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Sammy Hub &raquo; Feed" href="https://sammyhub.com/feed" />
<link rel="alternate" type="application/rss+xml" title="Sammy Hub &raquo; Comments Feed" href="https://sammyhub.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Sammy Hub &raquo; Galaxy S10 Lite will sell in India for Rs. 39,999 Comments Feed" href="https://sammyhub.com/2020/01/24/galaxy-s10-lite-will-sell-in-india-for-rs-39999/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/sammyhub.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3.2"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='genesis-simple-share-plugin-css-css'  href='https://sammyhub.com/wp-content/plugins/genesis-simple-share/assets/css/share.min.css?ver=0.1.0' type='text/css' media='all' />
<link rel='stylesheet' id='genesis-simple-share-genericons-css-css'  href='https://sammyhub.com/wp-content/plugins/genesis-simple-share/assets/css/genericons.min.css?ver=0.1.0' type='text/css' media='all' />
<link rel='stylesheet' id='magazine-pro-css'  href='https://sammyhub.com/wp-content/themes/sammyhub/style.css?ver=3.2.3' type='text/css' media='all' />
<style id='magazine-pro-inline-css' type='text/css'>


		button:focus,
		button:hover,
		input[type="button"]:focus,
		input[type="button"]:hover,
		input[type="reset"]:focus,
		input[type="reset"]:hover,
		input[type="submit"]:focus,
		input[type="submit"]:hover,
		.archive-pagination li a:focus,
		.archive-pagination li a:hover,
		.archive-pagination li.active a,
		.button:focus,
		.button:hover,
		.entry-content .button:focus,
		.entry-content .button:hover,
		.home-middle a.more-link:focus,
		.home-middle a.more-link:hover,
		.home-top a.more-link:focus,
		.home-top a.more-link:hover,
		.js .content .home-middle a .entry-time,
		.js .content .home-top a .entry-time,
		.sidebar .tagcloud a:focus,
		.sidebar .tagcloud a:hover,
		.widget-area .enews-widget input[type="submit"] {
			background-color: #eeeeee;
			color: #222222;
		}

		.menu-toggle:focus,
		.menu-toggle:hover,
		.nav-primary .genesis-nav-menu a:focus,
		.nav-primary .genesis-nav-menu a:hover,
		.nav-primary .sub-menu a:focus,
		.nav-primary .sub-menu a:hover,
		.nav-primary .genesis-nav-menu .current-menu-item > a,
		.nav-primary .genesis-nav-menu .sub-menu .current-menu-item > a:focus,
		.nav-primary .genesis-nav-menu .sub-menu .current-menu-item > a:hover,
		.nav-primary .genesis-nav-menu a:focus,
		.nav-primary .genesis-nav-menu a:hover,
		.nav-primary .sub-menu a:focus,
		.nav-primary .sub-menu a:hover,
		.nav-primary .genesis-nav-menu .current-menu-item > a,
		.nav-primary .sub-menu-toggle:focus,
		.nav-primary .sub-menu-toggle:hover {
			color: #eeeeee;
		}

		@media only screen and (max-width: 840px) {
			nav.nav-primary .sub-menu-toggle:focus,
			nav.nav-primary .sub-menu-toggle:hover,
			nav.nav-primary.genesis-responsive-menu .genesis-nav-menu a:focus,
			nav.nav-primary.genesis-responsive-menu .genesis-nav-menu a:hover,
			nav.nav-primary.genesis-responsive-menu .genesis-nav-menu .sub-menu a:focus,
			nav.nav-primary.genesis-responsive-menu .genesis-nav-menu .sub-menu a:hover,
			#genesis-mobile-nav-primary:focus,
			#genesis-mobile-nav-primary:hover {
				color: #eeeeee;
			}
		}

		


		a:focus,
		a:hover,
		.entry-content a,
		.entry-title a:focus,
		.entry-title a:hover,
		.genesis-nav-menu a:focus,
		.genesis-nav-menu a:hover,
		.genesis-nav-menu .current-menu-item > a,
		.genesis-nav-menu .sub-menu .current-menu-item > a:focus,
		.genesis-nav-menu .sub-menu .current-menu-item > a:hover,
		.menu-toggle:focus,
		.menu-toggle:hover,
		.sub-menu-toggle:focus,
		.sub-menu-toggle:hover {
			color: #253845;
		}
		
</style>
<link rel='stylesheet' id='wp-block-library-css'  href='https://sammyhub.com/wp-includes/css/dist/block-library/style.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='https://sammyhub.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.1.6' type='text/css' media='all' />
<link rel='stylesheet' id='cookie-notice-front-css'  href='https://sammyhub.com/wp-content/plugins/cookie-notice/css/front.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://sammyhub.com/wp-includes/css/dashicons.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-css'  href='//fonts.googleapis.com/css?family=Raleway%3A400%2C500%2C900%7CUbuntu%3A300%2C400%2C700&#038;ver=3.2.3' type='text/css' media='all' />
<link rel='stylesheet' id='simple-social-icons-font-css'  href='https://sammyhub.com/wp-content/plugins/simple-social-icons/css/style.css?ver=3.0.1' type='text/css' media='all' />
<script type='text/javascript' src='https://sammyhub.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://sammyhub.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://sammyhub.com/wp-content/plugins/genesis-simple-share/assets/js/sharrre/jquery.sharrre.min.js?ver=0.1.0'></script>
<script type='text/javascript' src='https://sammyhub.com/wp-content/plugins/genesis-simple-share/assets/js/waypoints.min.js?ver=0.1.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var cnArgs = {"ajaxurl":"https:\/\/sammyhub.com\/wp-admin\/admin-ajax.php","hideEffect":"fade","onScroll":"","onScrollOffset":"100","onClick":"","cookieName":"cookie_notice_accepted","cookieValue":"true","cookieTime":"2592000","cookiePath":"\/","cookieDomain":"","redirection":"","cache":"","refuse":"no","revoke_cookies":"0","revoke_cookies_opt":"automatic","secure":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://sammyhub.com/wp-content/plugins/cookie-notice/js/front.min.js?ver=1.2.50'></script>
<script type='text/javascript' src='https://sammyhub.com/wp-content/themes/sammyhub/js/entry-date.js?ver=1.0.0'></script>
<script type='text/javascript' src='https://sammyhub.com/wp-content/plugins/simple-social-icons/svgxuse.js?ver=1.1.21'></script>
<link rel='https://api.w.org/' href='https://sammyhub.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://sammyhub.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://sammyhub.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.3.2" />
<link rel='shortlink' href='https://sammyhub.com/?p=31760' />
<link rel="alternate" type="application/json+oembed" href="https://sammyhub.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fsammyhub.com%2F2020%2F01%2F24%2Fgalaxy-s10-lite-will-sell-in-india-for-rs-39999%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://sammyhub.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fsammyhub.com%2F2020%2F01%2F24%2Fgalaxy-s10-lite-will-sell-in-india-for-rs-39999%2F&#038;format=xml" />
<meta name="generator" content="Site Kit by Google 1.1.4" /><script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-104570-5', 'auto');
  ga('send', 'pageview');

</script>

<script async src="http://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
(adsbygoogle = window.adsbygoogle || []).push({
google_ad_client: "ca-pub-9732273244279029",
enable_page_level_ads: true,
tag_partner: "genesis"
});
</script><style type="text/css">.site-title a { background: url(https://sammyhub.com/wp-content/uploads/2017/03/cropped-sammyhub2k17.png) no-repeat !important; }</style>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script>
(adsbygoogle = window.adsbygoogle || []).push({
google_ad_client: "ca-pub-9732273244279029",
enable_page_level_ads: true,
tag_partner: "site_kit"
});
</script>
		<script type="text/javascript">
        setTimeout(function(){var a=document.createElement("script");
        var b=document.getElementsByTagName('script')[0];
        a.src=document.location.protocol+"//script.crazyegg.com/pages/scripts/0001/2131.js";
        a.async=true;a.type="text/javascript";b.parentNode.insertBefore(a,b)}, 1);
        </script>
      <link rel="icon" href="https://sammyhub.com/wp-content/uploads/2017/03/cropped-favicon-new-32x32.png" sizes="32x32" />
<link rel="icon" href="https://sammyhub.com/wp-content/uploads/2017/03/cropped-favicon-new-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://sammyhub.com/wp-content/uploads/2017/03/cropped-favicon-new-180x180.png" />
<meta name="msapplication-TileImage" content="https://sammyhub.com/wp-content/uploads/2017/03/cropped-favicon-new-270x270.png" />
</head>
<body class="post-template-default single single-post postid-31760 single-format-standard cookies-not-set custom-header header-image header-full-width content-sidebar genesis-breadcrumbs-hidden genesis-footer-widgets-hidden primary-nav"><div class="site-container"><ul class="genesis-skip-link"><li><a href="#genesis-content" class="screen-reader-shortcut"> Skip to main content</a></li><li><a href="#genesis-nav-secondary" class="screen-reader-shortcut"> Skip to secondary menu</a></li><li><a href="#genesis-sidebar-primary" class="screen-reader-shortcut"> Skip to primary sidebar</a></li></ul><nav class="nav-primary" aria-label="Main" id="genesis-nav-primary"><div class="wrap"><ul id="menu-primary" class="menu genesis-nav-menu menu-primary js-superfish"><li id="menu-item-20851" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-20851"><a href="http://www.sammyhub.com"><span >Home</span></a></li>
<li id="menu-item-20852" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-20852"><a href="https://sammyhub.com/about/"><span >About</span></a></li>
<li id="menu-item-20854" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-20854"><a href="https://sammyhub.com/contact-us/"><span >Contact Us</span></a></li>
<li id="menu-item-20853" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-20853"><a href="https://sammyhub.com/tip-news/"><span >Tip News!</span></a></li>
</ul></div></nav><header class="site-header"><div class="wrap"><div class="title-area"><p class="site-title"><a href="https://sammyhub.com/">Sammy Hub</a></p></div></div></header><nav class="nav-secondary" aria-label="Secondary" id="genesis-nav-secondary"><div class="wrap"><ul id="menu-secondary" class="menu genesis-nav-menu menu-secondary js-superfish"><li id="menu-item-20855" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-20855"><a href="https://sammyhub.com/category/mobile-phones/"><span >Phones</span></a></li>
<li id="menu-item-20857" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-20857"><a href="https://sammyhub.com/category/tablet/"><span >Tablets</span></a></li>
<li id="menu-item-29820" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29820"><a href="https://sammyhub.com/category/wearables-2/"><span >Wearables</span></a></li>
<li id="menu-item-20953" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-20953"><a href="https://sammyhub.com/category/tv/"><span >TV</span></a></li>
<li id="menu-item-20858" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-20858"><a href="https://sammyhub.com/category/hardware/"><span >Hardware</span></a>
<ul class="sub-menu">
	<li id="menu-item-29816" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29816"><a href="https://sammyhub.com/category/hardware/components/"><span >Components</span></a></li>
	<li id="menu-item-29818" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29818"><a href="https://sammyhub.com/category/hardware/storage/"><span >Storage</span></a></li>
	<li id="menu-item-29817" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29817"><a href="https://sammyhub.com/category/hardware/monitor/"><span >Monitor</span></a></li>
</ul>
</li>
<li id="menu-item-29819" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29819"><a href="https://sammyhub.com/category/software/"><span >Software</span></a></li>
<li id="menu-item-20861" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-20861"><a href="https://sammyhub.com/category/technology/"><span >Tech</span></a></li>
<li id="menu-item-20862" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-20862"><a href="https://sammyhub.com/category/home-appliances/"><span >Home Appliance</span></a></li>
</ul></div></nav><div class="site-inner"><div class="content-sidebar-wrap"><main class="content" id="genesis-content"><article class="post-31760 post type-post status-publish format-standard has-post-thumbnail category-latest-2 category-mobile-phones tag-galaxy-s10-lite tag-mobile-phones entry"><header class="entry-header"><h1 class="entry-title">Galaxy S10 Lite will sell in India for Rs. 39,999</h1>
<p class="entry-meta"><time class="entry-time">January 24, 2020</time> By <span class="entry-author"><a href="https://sammyhub.com/author/sid/" class="entry-author-link" rel="author"><span class="entry-author-name">Siddhanth</span></a></span> <span class="entry-comments-link"><a href="https://sammyhub.com/2020/01/24/galaxy-s10-lite-will-sell-in-india-for-rs-39999/#respond">Leave a Comment</a></span> </p></header><div class="entry-content"><div class="share-before share-filled share-small" id="share-before-31760"><div class="googlePlus" id="googleplus-before-31760" data-url="https://sammyhub.com/2020/01/24/galaxy-s10-lite-will-sell-in-india-for-rs-39999/" data-urlalt="https://sammyhub.com/?p=31760" data-text="Galaxy S10 Lite will sell in India for Rs. 39,999" data-title="Share" data-reader="Share on Google Plus" data-count="%s shares on Google Plus"></div><div class="facebook" id="facebook-before-31760" data-url="https://sammyhub.com/2020/01/24/galaxy-s10-lite-will-sell-in-india-for-rs-39999/" data-urlalt="https://sammyhub.com/?p=31760" data-text="Galaxy S10 Lite will sell in India for Rs. 39,999" data-title="Share" data-reader="Share on Facebook" data-count="%s shares on Facebook"></div><div class="twitter" id="twitter-before-31760" data-url="https://sammyhub.com/2020/01/24/galaxy-s10-lite-will-sell-in-india-for-rs-39999/" data-urlalt="https://sammyhub.com/?p=31760" data-text="Galaxy S10 Lite will sell in India for Rs. 39,999" data-title="Tweet" data-reader="Tweet this" data-count="%s Tweets"></div><div class="pinterest" id="pinterest-before-31760" data-url="https://sammyhub.com/2020/01/24/galaxy-s10-lite-will-sell-in-india-for-rs-39999/" data-urlalt="https://sammyhub.com/?p=31760" data-text="Galaxy S10 Lite will sell in India for Rs. 39,999" data-title="Pin" data-reader="Pin this" data-count="%s Pins"></div><div class="stumbleupon" id="stumbleupon-before-31760" data-url="https://sammyhub.com/2020/01/24/galaxy-s10-lite-will-sell-in-india-for-rs-39999/" data-urlalt="https://sammyhub.com/?p=31760" data-text="Galaxy S10 Lite will sell in India for Rs. 39,999" data-title="Share" data-reader="Share on StumbleUpon" data-count="%s shares on StumbleUpon"></div></div>
			<script type='text/javascript'>
				jQuery(document).ready(function($) {
					$('#googleplus-before-31760').sharrre({
										  share: {
										    googlePlus: true
										  },
										  urlCurl: 'https://sammyhub.com/wp-content/plugins/genesis-simple-share/assets/js/sharrre/sharrre.php',
										  enableHover: false,
										  enableTracking: true,
										  
										  buttons: {  },
										  click: function(api, options){
										    api.simulateClick();
										    api.openPopup('googlePlus');
										  }
										});
$('#facebook-before-31760').sharrre({
										  share: {
										    facebook: true
										  },
										  urlCurl: 'https://sammyhub.com/wp-content/plugins/genesis-simple-share/assets/js/sharrre/sharrre.php',
										  enableHover: false,
										  enableTracking: true,
										  disableCount: true,
										  buttons: {  },
										  click: function(api, options){
										    api.simulateClick();
										    api.openPopup('facebook');
										  }
										});
$('#twitter-before-31760').sharrre({
										  share: {
										    twitter: true
										  },
										  urlCurl: 'https://sammyhub.com/wp-content/plugins/genesis-simple-share/assets/js/sharrre/sharrre.php',
										  enableHover: false,
										  enableTracking: true,
										  
										  buttons: {  twitter: { via: 'sammyhubcom' } },
										  click: function(api, options){
										    api.simulateClick();
										    api.openPopup('twitter');
										  }
										});
$('#pinterest-before-31760').sharrre({
										  share: {
										    pinterest: true
										  },
										  urlCurl: 'https://sammyhub.com/wp-content/plugins/genesis-simple-share/assets/js/sharrre/sharrre.php',
										  enableHover: false,
										  enableTracking: true,
										  
										  buttons: {  pinterest: { media: 'https://sammyhub.com/wp-content/uploads/2020/01/GALAXY-S10-LITE.jpg', description: 'Galaxy S10 Lite will sell in India for Rs. 39,999' } },
										  click: function(api, options){
										    api.simulateClick();
										    api.openPopup('pinterest');
										  }
										});
$('#stumbleupon-before-31760').sharrre({
										  share: {
										    stumbleupon: true
										  },
										  urlCurl: 'https://sammyhub.com/wp-content/plugins/genesis-simple-share/assets/js/sharrre/sharrre.php',
										  enableHover: false,
										  enableTracking: true,
										  
										  buttons: {  },
										  click: function(api, options){
										    api.simulateClick();
										    api.openPopup('stumbleupon');
										  }
										});

				});
		</script><p><center><img src="https://sammyhub.com/wp-content/uploads/2020/01/GALAXY-S10-LITE.jpg" alt="Samsung Galaxy S10 Lite" width="750" height="667" class="alignnone size-full wp-image-31761" srcset="https://sammyhub.com/wp-content/uploads/2020/01/GALAXY-S10-LITE.jpg 750w, https://sammyhub.com/wp-content/uploads/2020/01/GALAXY-S10-LITE-300x267.jpg 300w" sizes="(max-width: 750px) 100vw, 750px" /></center></p>
<p>Shortly after <a href="https://sammyhub.com/2020/01/21/galaxy-note10-lite-india-launch-price/">announcing</a> the Galaxy Note10 Lite for the Indian market, Samsung has revealed the pricing and availability for the Galaxy S10 Lite. The phone&#8217;s Lite moniker doesn&#8217;t do justice as the phone seem to be nicely spec&#8217;d for modern needs. It is powered by Qualcomm&#8217;s Snapdragon 855 processor and packs in 8GB of RAM with 128GB of internal storage. The phone has a 6.7-inch Full HD+ (2400&#215;1080) Super AMOLED Infinity-O display and even features 4500mAh battery that supports 25W fast charging, which is bundled in the sales package. </p>
<p>The Galaxy S10 Lite also packs in decent camera sensors with triple camera support at the back. There&#8217;s the main 48MP sensor along with 12MP ultra-wide, 5MP macro lens and 32MP handling the selfie duty.</p>
<p>The phone is currently on pre-order with sales starting from February 4. Pre-order customers can avail one-time screen replacement worth Rs. 1,999 and additional cashback of Rs. 3,000 with ICICI Bank credit card. The phone will sell in Prism White, Prism Black and Prism Blue colours for Rs. 39,999. </p>
</div><footer class="entry-footer"></footer></article><h2 class="screen-reader-text">Reader Interactions</h2>	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2020/01/24/galaxy-s10-lite-will-sell-in-india-for-rs-39999/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://sammyhub.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='31760' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="867c6f3a7d" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="64"/></p></form>	</div><!-- #respond -->
	<p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p></main><aside class="sidebar sidebar-primary widget-area" role="complementary" aria-label="Primary Sidebar" id="genesis-sidebar-primary"><h2 class="genesis-sidebar-title screen-reader-text">Primary Sidebar</h2><section id="search-3" class="widget widget_search"><div class="widget-wrap"><h3 class="widgettitle widget-title">Search</h3>
<form class="search-form" method="get" action="https://sammyhub.com/" role="search"><label class="search-form-label screen-reader-text" for="searchform-1">Search the site ...</label><input class="search-form-input" type="search" name="s" id="searchform-1" placeholder="Search the site ..."><input class="search-form-submit" type="submit" value="Search"><meta content="https://sammyhub.com/?s={s}"></form></div></section>
<section id="simple-social-icons-2" class="widget simple-social-icons"><div class="widget-wrap"><h3 class="widgettitle widget-title">Subscribe Now!</h3>
<ul class="aligncenter"><li class="ssi-email"><a href="http://feedburner.google.com/fb/a/mailverify?uri=samsunghub&#038;loc=en_US" target="_blank" rel="noopener noreferrer"><svg role="img" class="social-email" aria-labelledby="social-email-2"><title id="social-email-2">Email</title><use xlink:href="https://sammyhub.com/wp-content/plugins/simple-social-icons/symbol-defs.svg#social-email"></use></svg></a></li><li class="ssi-facebook"><a href="https://fb.com/sammyhub" target="_blank" rel="noopener noreferrer"><svg role="img" class="social-facebook" aria-labelledby="social-facebook-2"><title id="social-facebook-2">Facebook</title><use xlink:href="https://sammyhub.com/wp-content/plugins/simple-social-icons/symbol-defs.svg#social-facebook"></use></svg></a></li><li class="ssi-gplus"><a href="https://plus.google.com/+sammyhub" target="_blank" rel="noopener noreferrer"><svg role="img" class="social-gplus" aria-labelledby="social-gplus-2"><title id="social-gplus-2">Google+</title><use xlink:href="https://sammyhub.com/wp-content/plugins/simple-social-icons/symbol-defs.svg#social-gplus"></use></svg></a></li><li class="ssi-rss"><a href="https://sammyhub.com/feed" target="_blank" rel="noopener noreferrer"><svg role="img" class="social-rss" aria-labelledby="social-rss-2"><title id="social-rss-2">RSS</title><use xlink:href="https://sammyhub.com/wp-content/plugins/simple-social-icons/symbol-defs.svg#social-rss"></use></svg></a></li><li class="ssi-twitter"><a href="https://twitter.com/sammyhubcom" target="_blank" rel="noopener noreferrer"><svg role="img" class="social-twitter" aria-labelledby="social-twitter-2"><title id="social-twitter-2">Twitter</title><use xlink:href="https://sammyhub.com/wp-content/plugins/simple-social-icons/symbol-defs.svg#social-twitter"></use></svg></a></li></ul></div></section>
<section id="text-13" class="widget widget_text"><div class="widget-wrap"><h3 class="widgettitle widget-title">Like us on Facebook!</h3>
			<div class="textwidget"><div class="fb-page" data-href="https://www.facebook.com/sammyhub/" data-tabs="timeline" data-height="300" data-small-header="true" data-adapt-container-width="true" data-hide-cover="false" data-show-facepile="true"><blockquote cite="https://www.facebook.com/sammyhub/" class="fb-xfbml-parse-ignore"><a href="https://www.facebook.com/sammyhub/">Sammy Hub</a></blockquote></div></div>
		</div></section>
<section id="text-15" class="widget widget_text"><div class="widget-wrap"><h3 class="widgettitle widget-title">Advertisement</h3>
			<div class="textwidget"><center><a href="http://www.dhgate.com/wholesale/cell-phones-smartphones/c105008.html"><img width="200" height="200" alt="cheap smartphones wholesale at DHgate.com" title="cheap smartphones wholesale at DHgate.com" src="https://sammyhub.com/wp-content/uploads/2017/11/samsungs8-200x200.jpg"></a></center>
</div>
		</div></section>
<section id="featured-post-7" class="widget featured-content featuredpost"><div class="widget-wrap"><h3 class="widgettitle widget-title">Recent Stories</h3>
<article class="post-31753 post type-post status-publish format-standard has-post-thumbnail category-latest-2 category-mobile-phones tag-galaxy-note tag-india tag-mobile-phones entry"><a href="https://sammyhub.com/2020/01/17/galaxy-note-10-lite-india-launch/" class="alignleft" aria-hidden="true" tabindex="-1"><img width="150" height="150" src="https://sammyhub.com/wp-content/uploads/2020/01/notify-me-note10lite-150x150.jpg" class="entry-image attachment-post" alt="Samsung Galaxy Note10 Lite" srcset="https://sammyhub.com/wp-content/uploads/2020/01/notify-me-note10lite-150x150.jpg 150w, https://sammyhub.com/wp-content/uploads/2020/01/notify-me-note10lite-100x100.jpg 100w" sizes="(max-width: 150px) 100vw, 150px" /></a><header class="entry-header"><h4 class="entry-title"><a href="https://sammyhub.com/2020/01/17/galaxy-note-10-lite-india-launch/">Galaxy Note10 Lite will launch in India on Jan 21</a></h4></header></article><article class="post-31750 post type-post status-publish format-standard has-post-thumbnail category-latest-2 category-mobile-phones tag-galaxy-s20 tag-galaxy-s20-plus tag-leak tag-mobile-phones entry"><a href="https://sammyhub.com/2020/01/13/samsung-galaxy-s20-shows-up-in-the-flesh/" class="alignleft" aria-hidden="true" tabindex="-1"><img width="150" height="150" src="https://sammyhub.com/wp-content/uploads/2020/01/galaxy-s20-plus-150x150.jpg" class="entry-image attachment-post" alt="Galaxy S20 Plus" srcset="https://sammyhub.com/wp-content/uploads/2020/01/galaxy-s20-plus-150x150.jpg 150w, https://sammyhub.com/wp-content/uploads/2020/01/galaxy-s20-plus-100x100.jpg 100w" sizes="(max-width: 150px) 100vw, 150px" /></a><header class="entry-header"><h4 class="entry-title"><a href="https://sammyhub.com/2020/01/13/samsung-galaxy-s20-shows-up-in-the-flesh/">Samsung Galaxy S20+ shows up in the flesh</a></h4></header></article><article class="post-31745 post type-post status-publish format-standard has-post-thumbnail category-latest-2 category-mobile-phones entry"><a href="https://sammyhub.com/2020/01/12/samsung-galaxy-xcover-pro-america/" class="alignleft" aria-hidden="true" tabindex="-1"><img width="150" height="150" src="https://sammyhub.com/wp-content/uploads/2020/01/galaxy-xcover-pro-150x150.jpg" class="entry-image attachment-post" alt="Samsung Galaxy XCover Pro" srcset="https://sammyhub.com/wp-content/uploads/2020/01/galaxy-xcover-pro-150x150.jpg 150w, https://sammyhub.com/wp-content/uploads/2020/01/galaxy-xcover-pro-298x300.jpg 298w, https://sammyhub.com/wp-content/uploads/2020/01/galaxy-xcover-pro-100x100.jpg 100w, https://sammyhub.com/wp-content/uploads/2020/01/galaxy-xcover-pro.jpg 750w" sizes="(max-width: 150px) 100vw, 150px" /></a><header class="entry-header"><h4 class="entry-title"><a href="https://sammyhub.com/2020/01/12/samsung-galaxy-xcover-pro-america/">Samsung intros the Galaxy XCover Pro in US for $500</a></h4></header></article><article class="post-31741 post type-post status-publish format-standard has-post-thumbnail category-hardware category-latest-2 category-monitor tag-ces-2020 tag-odyssey tag-odyssey-gaming-monitors tag-samsung entry"><a href="https://sammyhub.com/2020/01/11/samsung-introduces-odyssey-gaming-monitors/" class="alignleft" aria-hidden="true" tabindex="-1"><img width="150" height="150" src="https://sammyhub.com/wp-content/uploads/2020/01/CES-2020_Odyssey-Gaming-Monitor-Designer-Interview_main_7-150x150.jpg" class="entry-image attachment-post" alt="" srcset="https://sammyhub.com/wp-content/uploads/2020/01/CES-2020_Odyssey-Gaming-Monitor-Designer-Interview_main_7-150x150.jpg 150w, https://sammyhub.com/wp-content/uploads/2020/01/CES-2020_Odyssey-Gaming-Monitor-Designer-Interview_main_7-100x100.jpg 100w" sizes="(max-width: 150px) 100vw, 150px" /></a><header class="entry-header"><h4 class="entry-title"><a href="https://sammyhub.com/2020/01/11/samsung-introduces-odyssey-gaming-monitors/">Samsung introduces Odyssey gaming monitors</a></h4></header></article><article class="post-31730 post type-post status-publish format-standard has-post-thumbnail category-hardware category-latest-2 category-storage tag-ces tag-ces-2020 tag-hardware tag-ssd entry"><a href="https://sammyhub.com/2020/01/08/samsung-portable-ssd-t7-touch-comes-with-a-fingerprint-sensor/" class="alignleft" aria-hidden="true" tabindex="-1"><img width="150" height="150" src="https://sammyhub.com/wp-content/uploads/2020/01/t7-touch-black-150x150.jpg" class="entry-image attachment-post" alt="Samsung Portable SSD T7 Touch" srcset="https://sammyhub.com/wp-content/uploads/2020/01/t7-touch-black-150x150.jpg 150w, https://sammyhub.com/wp-content/uploads/2020/01/t7-touch-black-100x100.jpg 100w" sizes="(max-width: 150px) 100vw, 150px" /></a><header class="entry-header"><h4 class="entry-title"><a href="https://sammyhub.com/2020/01/08/samsung-portable-ssd-t7-touch-comes-with-a-fingerprint-sensor/">Samsung Portable SSD T7 Touch comes with a fingerprint sensor</a></h4></header></article></div></section>
</aside></div></div><footer class="site-footer"><div class="wrap"><p><p>Copyright &#x000A9;&nbsp;2020 · <a href="https://sammyhub.com">Sammy Hub</a> · Developed by <a href="https://ramdeodigital.com">Ramdeo Digital</a></p></div></footer></div><div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.8";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script><style type="text/css" media="screen"> #simple-social-icons-2 ul li a, #simple-social-icons-2 ul li a:hover, #simple-social-icons-2 ul li a:focus { background-color: #eeeeee !important; border-radius: 0px; color: #222222 !important; border: 0px #ffffff solid !important; font-size: 28px; padding: 14px; }  #simple-social-icons-2 ul li a:hover, #simple-social-icons-2 ul li a:focus { background-color: #222222 !important; border-color: #ffffff !important; color: #ffffff !important; }  #simple-social-icons-2 ul li a:focus { outline: 1px dotted #222222 !important; }</style><script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/sammyhub.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://sammyhub.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.1.6'></script>
<script type='text/javascript' src='https://sammyhub.com/wp-includes/js/comment-reply.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://sammyhub.com/wp-includes/js/hoverIntent.min.js?ver=1.8.1'></script>
<script type='text/javascript' src='https://sammyhub.com/wp-content/themes/genesis/lib/js/menu/superfish.min.js?ver=1.7.10'></script>
<script type='text/javascript' src='https://sammyhub.com/wp-content/themes/genesis/lib/js/menu/superfish.args.min.js?ver=3.2.1'></script>
<script type='text/javascript' src='https://sammyhub.com/wp-content/themes/genesis/lib/js/skip-links.min.js?ver=3.2.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var genesis_responsive_menu = {"mainMenu":"Menu","subMenu":"Submenu","menuClasses":{"combine":[".nav-primary",".nav-header",".nav-secondary"]}};
/* ]]> */
</script>
<script type='text/javascript' src='https://sammyhub.com/wp-content/themes/sammyhub/js/responsive-menus.min.js?ver=3.2.3'></script>
<script type='text/javascript' src='https://sammyhub.com/wp-includes/js/wp-embed.min.js?ver=5.3.2'></script>
<script async="async" type='text/javascript' src='https://sammyhub.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.3'></script>

		<!-- Cookie Notice plugin v1.2.50 by Digital Factory https://dfactory.eu/ -->
		<div id="cookie-notice" role="banner" class="cookie-notice-hidden cookie-revoke-hidden cn-position-bottom" aria-label="Cookie Notice" style="background-color: #000;"><div class="cookie-notice-container" style="color: #fff;"><span id="cn-notice-text" class="cn-text-container">We use cookies to ensure that we give you the best experience on our website. If you continue to use this site we will assume that you are happy with it.</span><span id="cn-notice-buttons" class="cn-buttons-container"><a href="#" id="cn-accept-cookie" data-cookie-set="accept" class="cn-set-cookie cn-button bootstrap button">Ok</a></span></div>
			
		</div>
		<!-- / Cookie Notice plugin --></body></html>
